中文的会员名,中文的话题,中文的搜索。都会报错!!!求大佬解决方法!

中文的会员名,中文的话题,中文的搜索。都会报错!!!求大佬解决方法!

By 暖男1995 at 2018-03-18
0人收藏 • 661人看过


21 个回复 | 最后更新于 16 天前
香草大叔
2018-03-19
#1

环境问题吧!

lincanbin
2018-03-19
#2

部署的环境?

不会是Windows + IIS吧?

eetsleepplay
16 天前
#3

回复#2 @lincanbin :

大佬,我就是Windows + IIS,也是和楼主一样的情况,请问怎么解决呢

lincanbin
16 天前
#4

回复#3 @eetsleepplay :

你用的哪个IIS的Rewrite插件?

eetsleepplay
16 天前
#5

回复#4 @lincanbin :

我问客服有没有Rewrite插件,他回复我用web.com nfig的

eetsleepplay
16 天前
#6

回复#4 @lincanbin :

web.co nfig  打错

lincanbin
16 天前
#7

回复#5 @eetsleepplay :

看来是高版本IIS自带的Rewrite了,我看看。

lincanbin
16 天前
#8

回复#6 @eetsleepplay :

我知道是哪个的。

lincanbin
16 天前
#9

回复#5 @eetsleepplay :

能截图让我看看你访问带中文参数的页面,报的什么错吗?

eetsleepplay
16 天前
#10

回复#9 @lincanbin :

就是提示404 Not Found 

eetsleepplay
16 天前
#11

回复#9 @lincanbin :

中文的标签404,中文搜索不会报错,但是无法搜索,搜索结果是所有帖子。中文用户名点击头像进入也是404

lincanbin
16 天前
#12

回复#10 @eetsleepplay :

image.png

你在这个文件加这行,然后访问中文用户名的资料页看看返回了什么?

var_dump($UserName);exit();


eetsleepplay
16 天前
#13

回复#12 @lincanbin :

好的,稍等

eetsleepplay
16 天前
#14

回复#12 @lincanbin :

显示string(10) "��΢Ц��è"

lincanbin
16 天前
#15

回复#14 @eetsleepplay :

估计又是GBK编码问题了。

eetsleepplay
16 天前
#16

回复#15 @lincanbin :

请问怎么解决呢

lincanbin
16 天前
#17

回复#16 @eetsleepplay :

我搜一下IIS的资料先。

lincanbin
16 天前
#18

回复#16 @eetsleepplay :

打开web.config,然后在

</configuration>

之前加入下面的代码:

    <system.web>
        <globalization culture="zh-CN" requestEncoding="utf-8" responseEncoding="utf-8" uiCulture="zh-CN" />
    </system.web>

然后重启IIS。

eetsleepplay
16 天前
#19

123.png打不开网页了,提示是这样


登 录


现在注册

QQ  登 录    Weibo  登 录    GitHub  登 录